Your shopping cart is empty.

Mode switch memory leak, switch gradually slower

Submitted by 5argon on Wed, 05/13/2020 - 15:53
5argon
Control Surface Studio User

Import both attached controller and script JSON file and install it into Live with Twister connected. It is a script with mode switch. To switch between 5 available modes, press the knob-button 1, 2, 13, 14, 15. (Counting from top left to bottom right)

1 Responses

Duplicate produce wrong components

Submitted by 5argon on Wed, 05/13/2020 - 14:55
5argon
Control Surface Studio User

Import the attached script. Check Volume Mode > Track 1 and click the cog icon. It inspect the right thing. Now duplicate an entire Volume Mode. Check the duplicated mode's Track 1. It now show Solo despite we just inspected a Track.

1 Responses

Mode switch spills value from prior mode

Submitted by 5argon on Wed, 05/13/2020 - 09:59
5argon
Control Surface Studio User

Try the script attached, the controller is DJTT Twister included in the app.

Button 1 and 2 switch between two modes. The first mode, Knob 1 will control Track 1's Volume. The second mode, Knob 1 will control Track 1's Send 1.

Adjust the volume of Track 1 at 0%, and the Send 1 at 100%.

When switching between 2 modes slowly, you can see Knob 1 could update and pick up either Volume or Send 1 from where it was successfully.

However try mashing both Button 1 and Button 2 to switch mode rapidly, and while doing so, also wiggle Knob 1 as you mash it.

0 Responses

Duplicate Button Causes Unexpected Behavior

Submitted by mjosephc on Sat, 04/18/2020 - 22:43
mjosephc
Control Surface Studio User

Hello! I just purchased CSS a couple of days ago and have really appreciated the functionality, namely that I don't have to learn Python to write remote scripts. :) So I'll start with a kudos for that! But I also want to add my name to the list of people who are seeing bugs with the Duplicate function of the program. I've spent the past 18 or so hours fiddling with things, trying to find steps to replicate the issue since I know that's most helpful for developers. Here's what I've been able to discover:

3 Responses

Ableton Automation Undo issue

Submitted by vdv on Tue, 03/31/2020 - 00:15
vdv
Control Surface Studio User

I've created my script and everything seems to be working well. T

here seems to be an issue with undo in ableton however. if I record automation, then stop the transport and press undo it only removes the last automation point. If i press undo again, then it steps backwards one point at a time which is tedious. Is there a way to have ctrl+z work as intended with other controller scripts? (recording automation using my novation as an example, pressing ctrl+z 3 times will remove the clip)

thanks!

5 Responses

Instant mapping Sampler Device

Submitted by sebcout on Mon, 03/23/2020 - 08:56
sebcout
Control Surface Studio User

Hi! Congrats for all the good work you've done. Having an instant hand control on all my third party plugins is truly changing the game.

However, mapping ableton native devices doesn't seem to work as well. Especially with the Sampler (but I only tried this one). Does the txt. file still relevant? The parameter numbers doesn't seem to be those indicated. Does some bugs exist?

In this example below, does it mean that "Filter Type" should be mapped on parameter number 9 (knowing Live working with banks of 8 parameters)?

0 Responses

Track Mute - MIDI Fighter Twister

Submitted by abelmariam on Sun, 03/01/2020 - 20:23
abelmariam
Control Surface Studio User

Unable to successfully map a track mute/solo parameter to my MIDI Fighter Twister button. I have played with different configurations with both the button and parameter-level control settings and haven't been able to get it to work. Any ideas ?

I viewed the example implementation presented in the "Live: MIDI Fighter Twister Ableton Script build" video - And I found that when watching closely the mute-mapping didn't actually work.

0 Responses

APC 40 mk2 Encoder LED Feedback

Submitted by revisionmusik on Sat, 01/25/2020 - 18:30
revisionmusik
Control Surface Studio User

Hey you guys,

i wrote a script for my APC 40 mk2, with works totally fine except for one thing: I can't manage to program the LED circles around the encoders. to show the value of the assigned parameter. Tried several changes within the 'LED Feedback' section...

Any ideas?

Thanks a lot!

2 Responses

Duplicate led feedback

Submitted by danicroitor on Sat, 01/25/2020 - 12:01
danicroitor
Pro User

Hi guys,
I think this is a bug. I've attached the script also.

I have an empty script. I've just put in there only 2 modes and "mode selector".

what is kinda weird is that even though I have mapped correctly the controller in controller settings, when I press a pad in order to change the mod, I get feedback on the pressed pad but also on another pad also.

The only thing that I could think is that the same pad had the same name: PAD 13 and PAD 14 (I have 2 groups of PADs)

4 Responses

M4L Parameter Assignment is random

Submitted by geraldbiggs on Fri, 01/24/2020 - 02:32
geraldbiggs
Control Surface Studio User

Hi there.

I have a possible bug with the midi fighter twister.

I've included a screenshot of the issue - where the same knob controls seemingly random knobs for the m4l devices.

I notice that the blue hand isn't showing - so maybe it's a setting on my part?

The default midi twister script (outside of css) works fine.

Thank you. I can provide more information as needed

3 Responses

Pages