Your shopping cart is empty.

[solved] Problem with CSS and Midi Fighter Twister

Submitted by Mathematics30 on Mon, 08/12/2019 - 14:40
Mathematics30
Control Surface Studio User

Hello!

I have try to configure the Midi Fighter Twister in CSS so i can have the four bank with the different led colors at disposition, and une the side buttons to switch between controls. To do so i have configured a controller with the 64 knobs and switch. But when if setting up some bank controls, only the 16 first encoders and switch from the bank A are working, and not the others.

I have checked with midi monitoring if all the midi assignements are corrects, and they are. I have try multiple configurations for the buttons type and nothing is working.

Am i missing something? Thanks for your help

Topic Category: 

28 Responses

Comments

Mathematics30
Control Surface Studio User
#1

Also a strange thing is occuring : when i sent one encoder from the bank A to control a midi on/off option, nothing is working except if i put the button setting to "obsolute", and then when opening the project, it is working perfectly ONLY after pressing the button 3 times. Strange..

Mathematics30
Control Surface Studio User
#2

UPDATE : the encoders seems to be working i was wrong. But the switches from bank B C and D still give no signal

Stevan
Forum Admin
#3

Hey Mathematics30,

It sounds like you have mapped only single side button. In order to select other three banks you will need to map more side buttons.

Or use the "Cycle" option if you plan to select all four banks by pressing a single button.

If you still have issues than post the screencapture of your settings in the Midi Fighter Utility.

Mathematics30
Control Surface Studio User
#4

Hello! Thanks for your response. Could you please indicate me where to locate the paramters your are talking about?

Im not sure if if getting understand here. Or if i do, sorry because english is not my native langage! :) I will try re-explain more clearly what i was trying to achieve :

Step 1 - With the midi fighter utility, configure colors on the four bank based on my needs
Step 2 - In CSS, inside controller manager, create a new controller with all the 64 rotary encoders and switches mapped into it with the midi monitoring system
Step 3 - In Ableton, configure templates of some vst with all the 64 rotary encoders and switches assigned to it via one and only parameter bank. Im using the midi fighter to switch between paramters, and not modes or parameters banking, so i can get the colors changes of the midi fighter fit the controls changes
Step 4 - Everything is working so far, unless when i try to map the switches from the B C and D bank, nothing happen. Only the rotary encoders from the bank B C and D are working, not the switches.

Also there is this strange behaviour as i was talking about : when i want to assign one of the switch (those which are working, from the bank A) for exemple to a mute button (so a valu between 1 and 0) into a VST, still via the parameter bank, if i select the "on/off" settings for the switch, nothing is happening. i have to select the setting "absolute" and the i get signal, but this is only working after pressing the switch 2 or 3 times. Note that i had to configure the switches to "CC TOGGLE" into midi fighter uitlity, otherwise the value will reset once i stop pressing the switch..

i hope explained the problem better. Here I have link to the post the controller settings and the script that i have made

Mathematics30
Control Surface Studio User
#5

PS : Normally the track type in the script was set to "selected", i was just doing some tests.

Mathematics30
Control Surface Studio User
#6

Sorry that was not the good script that i linked, here is the one.

upload files: 
John Carney
Forum Admin
#7

Hey, there's no need to create a new controller for the MIDI Fighter Twister. a pre-built Controller is available in the Import section or you can use Stevan's which is configured for all 4 virtual banks on the Twister.
You can download it here: https://remotify.io/community/question/stevans-css-controller-template-d...

Mathematics30
Control Surface Studio User
#8

Hey! Thanks for your answer. So i have try to made a new script now using the pre built controller you gave to me. Problem : now even the first 16 Knobs and switches arent working. They are working again once i switch in the settings to the pre built midi fighter controller with only 16 knobs and switches, or the one that i created.. But nothing is happening with the one you gave to me.

I really dont understand what im doing wrong here, because all of that process seems pretty easy to do and to understand, so i dont know where i could have messed something. I have try to make the simplest script possible (i'll link it to my post so you can check if there is anything wrong with it), and nothing is happening..

upload files: 
John Carney
Forum Admin
#9

Hey. I just tested your script with the 'DJ TT MIDI Fighter Twister' Controller file which comes with the App and it works.
I also tested with the 'Midifighter Twister 4-Bank CC knobs' Controller file and as you said it does not work.

I'm not sure why this is at the moment but I would suggest to use 'DJ TT MIDI Fighter Twister' for now.

Mathematics30
Control Surface Studio User
#10

Ok so i was not crazy, thanks for confirming that. I hope this problem will be solved in the futur, as i have especially buy the Midi Fighter Twister to use it with your application.

Also it will be cool if you can also confirm the problems that i have with the default Midi Fighter Twister template regarding assinging a simple on/off parameter : when assigned to a parameter in "paramter bank", the switch cannot be set to "on/off" (nothing is happening), but only on "absolute" in order to get it working (and setting it to CC Toggle instead of CC Hold in the Midi Fighter utility), and then you have to press it 2/3 times before it start working as intended. Everything is alright with simple things inside track functions like "mute" or "arm" , but not when using "parameter bank". I link you the script so you can see by yourself.

Thanks

upload files: 
joshuaman32
Pro User
#11

I'm having this exact same issue with the buttons on the MFT I can't get it to click buttons unless I use the same configuration you've listed.

joshuaman32
Pro User
#12

what's funny about this is that I got it to work for a second and then I suddenly recieved several thousand errors in the CSS log and then it magically deleted the entire controller from the control manager.

joshuaman32
Pro User
#13

So I got it to click some buttons in parameter banks for max 4 live devices that I created but I cannot get this thing to turn on or off devices at all.

Mathematics30
Control Surface Studio User
#14

Thanks for sharing your experience! I really hope that they can do something about it.

Mathematics30
Control Surface Studio User
#15

Hey!

Any chance that there are update about those problems?

John Carney
Forum Admin
#16

Hi,

I'm away at the moment without my Twister (why?!!).
I will check this out when I'm back next week.

Mathematics30
Control Surface Studio User
#17

Alright thanks! Im looking forwad to it :)

And enjoy your trip!

John Carney
Forum Admin
#18

Hey :)

I went through the problem controller and it seems the problem was due to lots of inputs being set to the exact same MIDI value/channel/type.
I've attached the updated the controller with all of the correct data (and improved the visual layout a bit).
Could you give it a go and let me know if it all works for you, if it does I will add this as the default Twister controller in CSS so everyone has access to all banks.

Thanks

Mathematics30
Control Surface Studio User
#19

Yo!

Awesome! i will check that and give you feedback as soon as i can!

thx

Mathematics30
Control Surface Studio User
#20

Some news : the rotary encoders/knobs are all working on the four banks now, awesome! However the problem with the "push" buttons (cant set to on/off, only on absolute, have to press 2/3times to work) is still here. But this is already a huge step forward! Nice

John Carney
Forum Admin
#21

Great to hear that all of the buttons and encoders are working.

With regards to your issue with needing to press 2/3 times for it to work. I just tested the buttons with a device on/off mapping and it works as expected (first press turns it off, second press turns it on).
If you're setting 'absolute' then you must have the mapping's 'control' option set to 'custom.
Depending on your settings inside here, you can make mappings fire in various ways.

Please upload a simple script for the new Twister controller which has the problem you are talking about and I will check it.

Mathematics30
Control Surface Studio User
#22

Hello.

May i ask you wiith which function did you test the on/off parameters? Because like i said on my earlier posts, this problem doesnt occur when using ableton features like mute/solo/arm etc or even ableton devices.

However it does appear when trying to map an on/off feature on a external plugin/VST via the "configure" menu of ableton.
If i send you one script, we need to have at least the same plugin/vst to check that; Do you got omnisphere 2?

Here i made a video to show you the problem : https://youtu.be/xUcJJkdMO1I

And sorry for my horrible english accent!!

John Carney
Forum Admin
#23

Hey,

Sorry yes I tested with Ableton functions, mute, volume and Device params.
I don't have Omnisphere 2 unfortunately, I checked for free but don't see one (anybody know if there's one available?)
I have NI Massive and a few others which I will test with.

p.s. I can't watch your video as it is set to private, please set it to unlisted or public :)

Thanks

Mathematics30
Control Surface Studio User
#24

Sorry my bad for the video, i have reupload a new version here :

https://youtu.be/483620lSJ34

One of my friend got massive i can got to his home if eventualy we only have that one to test. Ask me if you need anything!

John Carney
Forum Admin
#25

Hey,

I tested this and yes I get the same problem when using 'absolute'.
Try using 'relative' instead, this works perfectly for me.
Control type: 'Relative'
Left: 0
Right: 127
Steps: 1

Screenshot attached

Mathematics30
Control Surface Studio User
#26

Many thanks, i will try that as soon as possible

John Carney
Forum Admin
#27

I've test this out and it works well.
Updating the default Twister Controller in CSS with this version.

Mathematics30
Control Surface Studio User
#28

Hey!

Sorry, I was unable to have access to my setup the last two months, so sorry for being late.. I can confirm, this is working perfeclty with the instruction you gave to me. Many thanks ;)

Any chance that one day we see the on/off feature working properly with the midi fighter twister? I think that if it stays like that it will be hard for newcomers to get, jsut my two cents.

Anyway, thanks for having take care of the problem. I can roll in peace now (i think?)