Your shopping cart is empty.

setting up MF3D

Submitted by Robinjo on Thu, 01/13/2022 - 15:27
Robinjo
Control Surface Studio User

I have altered the MFT to MF3D and program some simple Session box with buttons. But the red box is in Ableton working, but the clip launch are not working. Do I need a mfs file for the remote? Or doing I something wrong?

Please help

Topic Category: 

10 Responses

Comments

Wim
Forum Admin
#1

Hello Robin,
I do not own a midi fighter so I can not test for you. It seems unlikely to me that you would need a mfs file.
My guess is that the 'MIDI Message Settings' from your Controller template doesn't have the right input.
Check MIDI type, channel and value of the pads.
If these are correct, you should be golden ;)

Robinjo
Control Surface Studio User
#2

I don't want to configure midi but clip launching. what software is used for mfs file generating?

Wim
Forum Admin
#3

Hi Robin, you just need to set the correct 'MIDI Message Settings' of each button/pad so Ableton can 'see' your buttons it needs to launch the clips.

Try this:
- go to 'Controller Templates'
- press the arrow next to your template
- turn on midi monitoring
- select a button or pad on the left pane
- push the according button or pad on your MF3D
- now the MIDI monitor will show the 3 MIDI settings of that button/pad

Each button/pad will have another MIDI value.
MIDI type and MIDI channel will probably stay the same for all buttons.

In the screenshot, you can see I pressed Pad1.

Good luck!

upload files: 
Robinjo
Control Surface Studio User
#4

Midi buttons are good setup. But when I setup the buttons to the Redbox grid they are not triggered in ableton. And midi is not needed in my opinion, is it?

This guy had the same issue:
https://remotify.io/community/question/midi-fighter-3d-clip-launcher-issues

I thought that remotely was for any controller working?

Wim
Forum Admin
#5

Remotify needs to know MIDI value, type and channel for each button. That way the buttons on your Midi fighter can 'speak' to Ableton and vice versa. That is the only MIDI setup that is needed as far as I know.
Once each button is set, the controller should work.

Till now I made scripts for 3 different controllers, once the correct MIDI settings per encoder were set up, it worked flawlessly. So normally it should work.
To me, it seems there is something going bananas between Ableton and the MIDI fighter.
Is the MIDI fighter recognized in the 'preferences' menu of Ableton?

Now I am only guessing here but maybe the MIDI fighter needs a driver on your OS?
Do you have the latest firmware installed on your MIDI fighter?
Maybe try another USB cable between your controller and your computer.
Or even another USB port. I have had devices that only work on the USB port they were installed on!!

I hope it is something as simple as that!
Good luck!

Wim
Forum Admin
#6

Also, do not use a USB hub to connect your MIDI fighter.

Wim
Forum Admin
#7

I might be kicking in open doors but did you already install the MIDI fighter utility? I just stumbled upon it while looking into your case.
https://store.djtechtools.com/pages/midi-fighter-setup#MF3D

Robinjo
Control Surface Studio User
#8

I already found the solution in your reply. I understand it now. I need to midi map the existing midi note to the buttons. Now it works. Thanks for your patience with me. ;-)

Robinjo
Control Surface Studio User
#9

Yes I installed already the software, but thought that is just needed the button data. Now I understand that is uses the inbuild midi to map it in the software. thanks for your explanation

Wim
Forum Admin
#10

You are welcome Robin!
Glad it is working now.
Happy scripting!