Your shopping cart is empty.

Script Failed to load ... again! CSS failed to start/quit

Submitted by danicroitor on Fri, 03/15/2019 - 19:51
danicroitor
Pro User

It happened me twice.
When I've tried to close the app i failed. I waited, waited, and nothing.
Another time it didn't wanna start. So I force quit and tried again.

After I've managed to start the app - the first time all my controllers disappeared. And it wasn't a problem with the file. I've checked and the file was empty 0 bytes... really strange. Anyway.. I build again the controller.

Not a similar thing happened and I could not export the script to Ableton or close the app. When I finally managed to restart the app, send the script to Ableton and tested, the script just it wasn't working. I've checked the log file and attached here, maybe I could get some help.

I don't wanna start building it again... it has already drove me crazy

thanks!

<code>
2019-03-15T21:49:03.503724: info: RemoteScriptMessage: (css_alfa_led) Initializing...
2019-03-15T21:49:03.665065: info: RemoteScriptError: Traceback (most recent call last):

2019-03-15T21:49:03.665101: info: RemoteScriptError: File "/Applications/Ableton Live 10 Suite.app/Contents/App-Resources/MIDI Remote Scripts/css_alfa_led/__init__.py", line 4, in create_instance

2019-03-15T21:49:03.665169: info: RemoteScriptError:
2019-03-15T21:49:03.665190: info: RemoteScriptError: return css_alfa_led(c_instance)
2019-03-15T21:49:03.665205: info: RemoteScriptError:

2019-03-15T21:49:03.665230: info: RemoteScriptError: File "/Applications/Ableton Live 10 Suite.app/Contents/App-Resources/MIDI Remote Scripts/css_alfa_led/css_alfa_led.py", line 37, in __init__

2019-03-15T21:49:03.665280: info: RemoteScriptError:
2019-03-15T21:49:03.665298: info: RemoteScriptError: self.listening_to_tracks()

2019-03-15T21:49:03.665335: info: RemoteScriptError: File "/Applications/Ableton Live 10 Suite.app/Contents/App-Resources/MIDI Remote Scripts/css_alfa_led/css_alfa_led.py", line 3254, in listening_to_tracks

2019-03-15T21:49:03.665892: info: RemoteScriptError:
2019-03-15T21:49:03.665910: info: RemoteScriptError: self.remove_listening_to_tracks()

2019-03-15T21:49:03.665947: info: RemoteScriptError: File "/Applications/Ableton Live 10 Suite.app/Contents/App-Resources/MIDI Remote Scripts/css_alfa_led/css_alfa_led.py", line 3293, in remove_listening_to_tracks

2019-03-15T21:49:03.666508: info: RemoteScriptError:
2019-03-15T21:49:03.666527: info: RemoteScriptError: if _track.arm_has_listener(getattr(self, "_mode" + active_mode + "_arm_listener")):

2019-03-15T21:49:03.666561: info: RemoteScriptError: RuntimeError
2019-03-15T21:49:03.666578: info: RemoteScriptError: :
2019-03-15T21:49:03.666593: info: RemoteScriptError: Master or Sendtracks have no 'Arm' state!
2019-03-15T21:49:03.666609: info: RemoteScriptError:

2019-03-15T21:49:03.666627: info: Exception: Script could not be loaded.
2019-03-15T21:49:03.666639: info: Exception: === Begin stack trace (pc:fn) ===
2019-03-15T21:49:03.666648: info: Exception: 0x00000001008232b3:0x0000000000000000
2019-03-15T21:49:03.666655: info: Exception: 0x00000001008935d0:0x0000000000000000
2019-03-15T21:49:03.666662: info: Exception: 0x0000000100894b47:0x0000000000000000
2019-03-15T21:49:03.666669: info: Exception: 0x000000010152bbec:0x0000000000000000
2019-03-15T21:49:03.666676: info: Exception: 0x000000010152eaa0:0x0000000000000000
2019-03-15T21:49:03.666683: info: Exception: 0x00000001015339c3:0x0000000000000000
2019-03-15T21:49:03.666691: info: Exception: 0x00000001015335a3:0x0000000000000000
2019-03-15T21:49:03.666697: info: Exception: 0x000000010153253a:0x0000000000000000
2019-03-15T21:49:03.666706: info: Exception: 0x00000001016d934f:0x0000000000000000
2019-03-15T21:49:03.666715: info: Exception: 0x00000001012bc34a:0x0000000000000000
2019-03-15T21:49:03.666723: info: Exception: 0x00000001016d934f:0x0000000000000000
2019-03-15T21:49:03.666731: info: Exception: 0x00000001012d1bd5:0x0000000000000000
2019-03-15T21:49:03.666740: info: Exception: 0x0000000100a1bb49:0x0000000000000000
2019-03-15T21:49:03.666747: info: Exception: 0x0000000100a11def:0x0000000000000000
2019-03-15T21:49:03.666756: info: Exception: 0x0000000100c4180a:0x0000000000000000
2019-03-15T21:49:03.666764: info: Exception: 0x0000000100b34d8a:0x0000000000000000
2019-03-15T21:49:03.666773: info: Exception: 0x0000000100b36ea3:0x0000000000000000
2019-03-15T21:49:03.666780: info: Exception: 0x0000000100b555fb:0x0000000000000000
2019-03-15T21:49:03.666788: info: Exception: 0x00007fff35dc5090:0x0000000000000000
2019-03-15T21:49:03.666796: info: Exception: 0x00007fff35dc46c9:0x0000000000000000
2019-03-15T21:49:03.666805: info: Exception: 0x00007fff35c61954:0x0000000000000000
2019-03-15T21:49:03.666812: info: Exception: 0x0000000100b4230f:0x0000000000000000
2019-03-15T21:49:03.666820: info: Exception: 0x00007fff35c4f19d:0x0000000000000000
2019-03-15T21:49:03.666828: info: Exception: 0x0000000100b4d839:0x0000000000000000
2019-03-15T21:49:03.666836: info: Exception: 0x00007fff65952ed9:0x0000000000000000
2019-03-15T21:49:03.666861: info: Exception: === End stack trace ===

</code>

Topic Category: 

2 Responses

Comments

John Carney
Forum Admin
#1

From the pasted Error Report, it's probably a Reaction setting.
Can you export the script.json file and upload it here?
(you should now see an export button next to your Script)

danicroitor
Pro User
#2

I don't know what it is cause at some point it start working again.
I've made an export of the script and then start to delete stuff from the script in order to figure out what could be the problem but it didn't worked.
After a while it just tart working again by himself.

upload files: