Remote Scripts Folder Will Not Update

Submitted by wezelboy on Sat, 04/29/2017 - 20:26
pro user
I know that this is more of an "Ableton" related issue rather then a "Remotify" issue but I thought maybe someone here could help as I am at my wits end! The first time I made a script with remotify and added it to the correct folder it worked great, it showed up in the drop down menu and I was able to select it and everything. I soon realized that I had made some major mistakes in my mapping and deleted it from the Midi Remote Scripts folder immediately. I made my changes and put the new file back in the folder but when i started up live again it was nowhere to be seen in the control surfaces drop down menu! Here are the things that I have tried with no luck: Uninstall/reinstall of Ableton Deleting my preferences files Deleting the Midi Remote Scripts file completely and re adding it. It would seem to me that the problem stems from the Ableton browser itself not updating, which a quick google search has shown me newer versions of Ableton are notorious for. I just do not understand why it worked so well the first time but not the times after. I also know that it is not a naming issue of the file itself because after my uninstall/reinstall I had to re add my other custom scripts from another site and those will not show up either. Any help I could get on the subject would be greatly appreciated, thank you!

2 Responses


John Carney
pro user


Sorry to hear you're having problems with your setup.

If it's anything midi remote script related, you'll have errors in your log.txt file.
Have a search in the file for "RemoteScriptError"
Or you can post it here/ email me and I'll take a look myself.

Also, this article has some details on broken scripts:



pro user

Hi John, I appreciate the fast reply! I did however find the solution! It was an indexing error! I had a folder INSIDE the folder that contained the necessary files, instead of the folder itself in my midi remote scripts folder. I was only able to come to this conclusion because of the log.txt. I very much appreciate your help in the situation John, thank you!