🔥 Lifetime deal! Get Control Surface Studio for Just £67 👉 Click Here To Get It
Time left... mailtimers.com
⚠️ Lifetime licenses are ending soon, get yours before they're gone ⚠️
Your shopping cart is empty.

Problem on knob 3 with MidiMix

Submitted by Smax2k8 on Fri, 05/26/2023 - 14:31
Control Surface Studio User


Your software is really great!

I have two Akai MidiMix controllers and two scripts. I also have two controller templates (MIDI channel 1 for the first one and 2 for the second one).

Everything works very well after many adjustments. The first controller controls 8 tracks, and the second controller controls 6 return tracks. I have 3 modes (Global, Sends, Sends 2).

As I said, everything works very well, except for Knob 3 not work on the second controller (Channel 2, value 24).

It should control Return Track 3 (C):

In Global mode: Device 1, Parameter Bank 1.
In Sends mode: Send 1.
In Sends 2 mode: Send 4.
Knob 3 works because I can manually map it in Ableton.

I've tried the script on two computers, and I have the same problem.

You can try the "akai_midimix_2.json" script with the "midimix_2.json" template, and you'll see that Knob 3 doesn't work (i have also added screenshots and logs to the Google Drive folder) : https://drive.google.com/drive/folders/1UyMvQvBYjsploh2tDPbpZ0XkUGj5ARGP...

Thank you

Topic Category: 

3 Responses


Control Surface Studio User

I have removed and added Knob 3, and now I can no longer install the script to Ableton.

The 'Controller Input' selected for 'Send 1' mapping no longer exists in attached controller. Select an available controller input in the mapping's settings form.

Control Surface Studio User

When I set Knob 3 to Channel 1, it works. I don't understand why Knob 3 doesn't work on Channel 2. All the other knobs work fine except for Knob 3.

Control Surface Studio User

Hi Smax2k8,
Going from your last message, it seems that knob 3 is set on Midi Channel 1 in your Akai MidiMix instead of Channel 2.
Check with the MidiMix editor if that is the case and set it to Midi Channel 2.
That should do it. ;-)