Your shopping cart is empty.

maybe, I am too stupid?

Submitted by plastic mind on Tue, 03/26/2019 - 18:21
plastic mind
Control Surface Studio User

... hello!

i've really done everything as described in the tutorial, but really it doesn't work + and nothing happens, when i press the buttons or turn the knobs ...

...for example: i create a simple one-mode and just define one simple -play-button, but nothing happens, when I press the button or the other buttons ... maybe, there ist an general fault, that I make ... I really don't know: so I ask you, if you can help me?

i use ableton live 10.0.6 and want to define a aka-midimix + i don't have any css-knowledges, but I thought, i would understand this program :(

Topic Category: 

6 Responses

Comments

plastic mind
Control Surface Studio User
#1

... maybe, someone could send me his script - for aka-midimix - als a zip-file, so i could compare it with mine, that would help me :)

John Carney
Forum Admin
#2

Hi there,

Yes I can help you with this. First thing though, have you configured your settings correctly and are you able to select your script in Ableton's Preferences MIDI Tab?
Here is the Configuration tutorial: https://remotify.io/product/control-surface-studio/documentation/step-by...

Next. You're in luck as the Controller file for Akai MIDI Mix is already available and the script 'My First Script' is configured to be used with it. They are both included in the App when you first download it.
if they aren't there, you can import them in the Controller & Script Import sections.
Here is a tutorial on importing Scripts
https://remotify.io/product/control-surface-studio/documentation/step-by...

Once you have them both in the App, all you need to do is attach the MIDI Mix to the Script (see the attached image) and click the 'install button'. This will install the script into Live, ready for use.
Here is a tutorial on installing & activating your Script into Ableton:
https://remotify.io/product/control-surface-studio/documentation/step-by...

The MIDI Mix seems to auto assign the default script in Live's Preferences when you connect it, so just make sure you deselect it in the MIDI Tab and only have yours assigned.

Hope this helps.

upload files: 
plastic mind
Control Surface Studio User
#3

... thank you very very much for the answer :) i received your mail, too + great support!

1.: yes, all settings are sure correctly and working
2.: i didn't create a controller-file and used your original pre-setted aka-midimix-script and I didn't change anything
3.: the new scripts are correctly installed and i can choose them

maybe, i could send you my created script, maybe, i made a fault ... but i think,iI made everything correct?!

John Carney
Forum Admin
#4

As mentioned in my email response just now, we have received and are currently investigating your script. We will get back to you once we have a solution to your problem.

plastic mind
Control Surface Studio User
#5

... really perfect support!!! i will wait ... maybe, other users might have the same problem and it will be solved than :)

John Carney
Forum Admin
#6

Hi, hopefully you have received my email earlier today.
Since then we have solved this issue and it was due to the MIDI Mix Controller file having missing data. We have now updated this and recommend that you delete the existing one in your App and import the new version by using the Controller Import section (to display the Import section, click the right most button next to the title 'Controller Manager'.

Once other thing we noticed with your Script, if you change the attached Controller in your Script's settings, some buttons are being added in your Session Box Mapping which is preventing it from being installed.
You just need to go in to this Mapping and remove the 4 Buttons from the Clips.
This is a bug which will fix asap.

In summary, no you are not 'stupid'. Everything you did was correct!

Thanks

John