Your shopping cart is empty.

Disable Session Box LED Control

Submitted by Image_Engine on Wed, 08/11/2021 - 05:02
Image_Engine
Control Surface Studio User

I have to use a session box when navigation to another mode...which is fine...but Im managing all the LED interaction with reactions.

HOWEVER

I have ALL the session box LED assignments set to none
In various instances, ie track arm, the session box seems to be getting called after my code and turning the LEDS off in that track ei because the session box is the last call regardless of its positioning.

SO

The easy fix is just to set up a box outline to maintain visual cue but how can a minimal box be set up?

I mucked around with SessionComponent but a simple example of a barebones setup would be amazing

ie just the frame, no clipslots, no skinning etc

Cheers

Topic Category: 

7 Responses

Comments

John C
Forum Admin
#1

Hi,

Untested but try this...
In def session_box:
Comment out all of the lines which have a call to 'feedbackArr'

Image_Engine
Control Surface Studio User
#2

Thanks John
Also, this code worked previously but now does not

range(self._session.width())

as a parameter for a GUI Loop?

This is being called in a mode that def has a sessionbox defined and sits above the code in the heirarchy

Cheers

Image_Engine
Control Surface Studio User
#3

Actually, the ':' was being wrapped back on to the next line...wasnt doing that before and I have no way I could do that during compilation

Image_Engine
Control Surface Studio User
#4

But Still having the issue

range(self._session.width())

Creates the error;

(TEST) There's a problem with 'Action Block 2' in reaction 'K41.01-64 LED mode refresh' (from 'modifier - m11 modifier was updated' listener) >>
>> 'NoneType' object has no attribute 'width'

Image_Engine
Control Surface Studio User
#5

Sorry if its not clear;
Why is this now not working when it worked a while back;

range(self._session.width())

ie nothing has changed in code or positioning and this was previously used across the project

Cheers

John C
Forum Admin
#6

Hey,
This error...
'NoneType' object has no attribute 'width'
sounds to me that you're trying to call _session.width before the sessionbox has been created in the order of the code.

Image_Engine
Control Surface Studio User
#7

Yep...thats what I thought but I have tried it as the first element in the mode and then as the last element with exactly the same nonetype ie undefined reference....thats the weird thing; just doesnt make sense. self._sess...that is referring to the session box locally defined for the mode. I am using the reference in modifier listener script ie global reference