Your shopping cart is empty.

CSS Version 2.6.3 is out - Add Notes and more...

Submitted by Remotify Team on Fri, 01/14/2022 - 13:04
Remotify Team
Forum Admin

Hi all and a Happy New Year from the Remotify Team!
We have just release version 2.6.3 which adds some great new pieces of functionality to the UI and improves on others:
New: 
1. A section for writing notes has been added to the following forms:
  - Script Settings Form
  - All Mapping Type Forms
  - Each Action Block in a Reaction
  - Controller Template Settings Form
  - All Controller Input Type Forms

2. Duplicate, Move up & Move down buttons are now available for the following sections inside the Reactions Mapping type:
- Action Blocks
- Reaction Conditions
- Reaction Actions

Improved: 
1. The Log Menu now displays current size (in mb) of the log.txt file.
log file size

2. Midi Learn/Monitoring can now be turned on/off directly inside the 'MIDI Message Settings' section of a controller input
midi learn button

3. Removed on/off button inside MIDI Monitor menu. It is now always monitoring incoming midi signals (no longer displays a red dot when on).
4. Each script in he 'script import section' now shows a description, and a link to it's webpage for more information.

Fixed:
1. In Reactions, all Device Parameter listeners have now been fixed. Previously they were generating incorrect code. See this comment in the forum for more details: https://remotify.io/community/question/looper-status-led-midi-feedback#comment-3056
2. In Reactions, the descriptions for all actions using 'beats' and similar action params was incorrect. These have now been updated. More details on this issue here: https://remotify.io/community/question/ableton-fixed-length-recording-without-push-it-possible#comment-2963 

Go here to view the full changelog

Topic Category: 

28 Responses

Comments

Wim
Forum Admin
#1

Sweet..
Thanks for the upgrade!

benwadub
Control Surface Studio User
#2

files doesn't t work on Mac OS X image not recognized

John C
Forum Admin
#3

What do you mean Ben? are you unable to download and install 2.6.3?

rodolfo.rribeiro
Pro User
#4

After this update navigation in PARAMETERS BANKS with Scroll in buttons with 'Incremets' and 'Decrements' stopped working.
It's only working with knobs which made me very upset..
Displays the message of: changed active bank to
Can you explain this?

rodolfo.rribeiro
Pro User
#5

still about browsing in PARAMETER BANKING:

I carried out several tests and I really believe that it was due to the update, I think it's valid for you to check this, because I'm using an old script that I had saved, because the new ones I install are not working

rodolfo.rribeiro
Pro User
#6

Where can I DOWNGRADE?

Wim
Forum Admin
#7

Hi Rodolfo,
I just tried scrolling in a parameter bank with an increment and decrement button and it works over here.
I guess you can always try to downgrade and try your script again. To downgrade just open the previous ControlSurfaceStudio file ( the one you downloaded last time) and you can use version 2.6.2
Wishing you succes!

Wim
Forum Admin
#8

What is odd, your screenshot says Control Surface 3, mine says 1..

upload files: 
Wim
Forum Admin
#9

I tried to run the script in 2.6.2, got an EPERM system error, tried it again, no errors now but the incr-decr buttons didn't work..
I am running out of time right, but tonight I will try again.

What I do really like about the 2.6.3 version; I get no more crashes :)
2.6.2 crashed frequently on me when installing the script into Ableton. Resulting in files of 0 bytes.
Didn't have that happening in 2.6.3 (yet ;)) fingers are crossed.

Wim
Forum Admin
#10

Ok now, reading your posts again, I think I misunderstood you.

Increment/decrement works all right within "Parameter Bank". I thought that was the problem you were having when I read your first post. Reading your second post makes it clear that is not what you intended.

'Parameter Bank' browsing in 'Parameter Banking' does not work for me too with increment/decrement buttons. That is to say, I can not get it to work. Not in 2.6.2 nor in 2.6.3, I only recently joined Remotify, so I can only test those 2 versions. I suppose you used an even earlier version.

Just some side info:
The one time I tried to use parameter banking, I was trying to call a 'Parameter Bank' through 'Parameter Banking' with the use of a modifier.
I got an error in my PY file:
line 1742: self.parameter_banking_1_id_13["banking_number"] = self.get_modifier_value(\"m1\")
I manually corrected the error by removing both the '\'. But then got an AttributeError:
'css_tweaker_8_track_modifier' object has no attribute 'device_id_7_bank_parameters_-1'
and the script still didn't work as it should.
Since I could not find any questions about this on the forum, I supposed I did something wrong and came up with a 'Reaction' script that worked for me, so I didn't bother anymore.

Maybe that error in parameter banking is also related to your problem?

I'm guessing John (or somebody else) will have some more info or solution in the near future.

rodolfo.rribeiro
Pro User
#11

Exactly friend!
For im it worked in version 2.6.2
After the upgrade it doesn't work anymore, and this is really very important for me.... I'm really upset

rodolfo.rribeiro
Pro User
#12

I don't have the previous file to downgrade!

rodolfo.rribeiro
Pro User
#13

This is the function that is not working after the upgrade

Wim
Forum Admin
#14

Hello Rodolfo,

I only have the PC version of v2.6.2, If you are on windows, mail me at hihim31455@nabajin.com, I will send you the file. It's a temporary email since I don't know Remotify's policy about sharing files.

I also tried in both versions and I can not make it work. But then again, I don't have that much experience in CSS, I might be doing something wrong.
Till soon.

John C
Forum Admin
#15

Hi rodolfo,

Nothing changed between 2.6.2 and 2.6.3 with regards to the parameter banking mapping type.
However, we just tested this and yes found an issue with increment/decrement in parameter banking...

This has now been fixed (on the server) so if you re-install your script, it should now work for you.

Note:
2.6.2 can currently still be downloaded from here for a limited time:
Mac: https://remotify.io/releases/mac/ControlSurfaceStudio2.6.2.dmg
Win: https://remotify.io/releases/windows/ControlSurfaceStudio2.6.2.exe

Wim
Forum Admin
#16

Great!
Thank you John!!

rodolfo.rribeiro
Pro User
#17

Thank you John!
Glad to have a quick response and to be able to collaborate to correct the error!

Thanks!

rodolfo.rribeiro
Pro User
#18

Hello John!
I don't know if this is the appropriate place for this suggestion, but it would be nice if you could put the 'LOCK TO CONTROL SURFACE' command just like some manufacturers' scripts have.
attached photo

Wim
Forum Admin
#19

Hello Rodolfo,

If I'm not mistaken, this is already possible in Remotify by using Modes.

I have a Reaction where I 'lock' my controllers to a device by pressing a button (for instance Mode 3). If I then change to another device or track, the controller stays locked to that first device (still in Mode 3).
;-)

rodolfo.rribeiro
Pro User
#20

Hi Jhon!
I have problems again and I believe it is related to the same as before, when installing my script I get the following message:

Error
get_device_chain_target error: we cant currently handle device selectors of type: . Called by config_module

rodolfo.rribeiro
Pro User
#21

Hi john!
I believe that again it could be someone's error on your internal server, this error appears when I add:

'MODE 4" -> Track Selector 4 -> Device Selector 4 -> Parameter Bank-> PARAMETER = 15

When I finish this and go to install my script, I get the message:

error
get_device_chain_target error: we can't currently handle device selectors of type: . Called by config_module

And it doesn't install my script... I hope it gets resolved quickly....

rodolfo.rribeiro
Pro User
#22

curious that the error only appears when I add the number of parameters, if I add 1 the error does not appear, but if I add 15 the error happens

Wim
Forum Admin
#23

Hello rodolfo,

Short answer:
"get_device_chain_target error" -> John said about that: "If you get this error, create a new script, drag all of the modes/mappings into it and you should be good to go."

About the parameters, I noticed that if you for example put in 15 in 'Parameter Bank', it would sometimes generate 14 parameters, generating that error. A workaround is to first put 14 in 'Parameter Bank', and then 15. (https://remotify.io/community/question/parameter-bank-bugcorrupts-script...)

Anyway John's solution has always worked! :-)

rodolfo.rribeiro
Pro User
#24

It doesn't solve this for me! I need all my parameters in a bank

Wim
Forum Admin
#25

Hi Rodolfo,
Sorry to hear that, I meant my last sentence to be 'has always worked for me'..
It sure is possible to have 15 parameters, I have 'Parameter Banks' running with up to 35 parameters.
Anyway, maybe try again? It can never hurt!
Hope it works, good luck!

rodolfo.rribeiro
Pro User
#26

Fiz o que o John falou no link on top of what you posted, and it worked again!

Wim
Forum Admin
#27

Great!
Glad it worked out, thanks for letting us know!

John C
Forum Admin
#28

Fix added to prevent running into the get_device_chain_target error https://remotify.io/community/question/getdevicechaintarget-error-fixed