Your shopping cart is empty.

Color Feedback confusion?

Submitted by Lextasy on Mon, 07/11/2022 - 14:11
Lextasy
Control Surface Studio User

Hey there so I started a new script after getting a MFtwister. I am currently trying to work out some preliminary things before deep diving into trying to make a keyboard free setup.

My current confusion seems to be color feedback. I have a button which is set to toggle track activator value on/off through a reaction. When the selected track is on the light comes up, when the track is off it goes out.

The issue I am having is when other information is sent the light seems to go out regardless if the activator value has changed or not. I noticed this first when turning that same knob in which the button is attached. I found I can add a listener to re-send the value when the knob is spun which allows it to stay on. Next I noticed it seems to go out if I change selected device on that track with my mouse. Ie if I use that knob to change the device selected it will stay on, but if I simply click it goes out.

Any suggestions?

Topic Category: 

6 Responses

Comments

John C
Forum Admin
#1

Do you have any other LED feedback going to that button (reaction or other mapping types) which could be turning LED off?

Lextasy
Control Surface Studio User
#2

I believe starting I just had it set for when the button was pressed or when the status changed. I have a number of things now trying to send as a tinkering experiment really and therefore likely have things that aren't needed? I have tried to upload the file but it seems it comes back saying "Can't be saved. An Unknown error has occured" I exported it with name.json not sure what's wrong.

Also it looks like trying to come in an tinker today I can't install to Ableton anymore. I am getting the following error: "You do not have an active session. please try logging in again control surface studio"

I tried logging out and back in and nothing. I tried logging out, closing, and reopening and same result. Going to restart my computer here completely immediately following this post to see if that changes anything.

John C
Forum Admin
#3

I checked and your user account has license Control Surface Studio so you should have access.
If you have multiple accounts on remotify.io, just double check that you're logging into the correct one.

Lextasy
Control Surface Studio User
#4

Thanks for checking in on that. I doubled back and it looks like the account I am logged into matches my account here. I am still unable to install with the same error.

If it helps I am on Windows 10, and using CSS 2.7

John C
Forum Admin
#5

On your computer, if you go to your home directory > control surface studio, in the scripts folder are the json files for all of your scripts.
If you do a 'find in file' type search, and search for the name of the script, you can then get the json file and upload it here.

Lextasy
Control Surface Studio User
#6

Yep yep! I was selecting the Json however the upload was being mean to me. Seems to be nice now. Here is my messy crap trying to tinker and figure things out one at a time.

upload files: