Your shopping cart is empty.

Buggy?

Submitted by Annette Brosin on Tue, 01/26/2021 - 00:55
Annette Brosin
Control Surface Studio User

Hi there,
I just went through a whole wave of different CSS successes and failures in the course of 2 hours. I"m using a Beatstep (not pro) and had originally thought of using its banks in order to programm a script within a single mode. However, the fact that changing the bank on the beatstep didn't lead to the LEDs changing according to what was going on in Ableton (I had everythin selected on Ableton Preferences to midi in and out for track and remote, as well as inside the script - the beatstep just wouldn't update the LED states when changing banks) led me to try modes. So I finally had some time on my hands to try out using modes and had programmed 4 modes (both shift and switch) and it was all working perfectly with LEDs changin correctly. Then I tried to add devices for my FX mode and from then on the bugs started: it somehow affected all my tracks in my mixer mode so that there was no mute buttons anymore. So I reprogrammed them, but then the LEDs stopped updating. I also tried getting the old files and import them from the Ableton "Show Package Contents" but that didn't help for some reason.

Has this happened to anyone?
I was super happy an hour ago, now not so much anymore..
Thank you :)

Annette

Topic Category: 

2 Responses

Comments

Annette Brosin
Control Surface Studio User
#1

Update: After restarting my Mac things have settled to normal. LEDs working perfectly! I'm just gonna roll with it :)

John C
Forum Admin
#2

That's certainly odd, and the fact it settled down after restarting your Mac is even more odd!
Keep us updated, if the issues come back again.

John