Black Friday Deal!
Get Control Surface Studio for $55 with code: black2022
Time left to get it...
mailtimers.com
Your shopping cart is empty.

Big trouble with deviceselector with Fader Fox EC4

Submitted by Ciura81 on Mon, 10/24/2022 - 20:53
Ciura81
Control Surface Studio User

Hallo,

I have a big trouble withe the script,

I can use every Stock instrument and there in every Button and Knob when I map it in the scrip.

But when ad a Device to the script to controll a Plugin or an Audioeffect, it does not work.

I tried it for mor the hundred times Wit one Konb or One Button and it does not work.

I this a conflikt with the Faderfox?
Or is it a Problem because I use Ableton in windows. I need a solutiuon I can send my script

I can send also my script for my Operator solution that is working fantastic. But the Device in my other scrips doent work.

Topic Category: 

4 Responses

Comments

Buster_Delmonico
Control Surface Studio User
#1

Hi,

I'm not sure I understand what you are saying, so I will start by repeating what I think I hear you saying. I think you are saying that your scripts work fine with the stock Ableton Instruments and effects, whatever you want to do you can do. But when you try to use your scripts (or write them for) VST or AU instruments or effects, nothing seems to work. Did I understand you correctly?

If so, the problem could be simply that many VST (and I assume AU) plugins do not automatically "map" any "remote controllable" parameters by default. I suspect the reason is because Live only allows 128 remote controllable parameter mappings per device and some VST devices (like Massive) "expose" more than 512 parameters to "remote control". This is a good thing in my book, how are they supposed to know which of the 512+ are my favorite 8 or 16?

Have you opened the VST device's "twisty" (triangle next to the wrench)? Do you see any device parameters listed? Or does it say, To add plug-in parameters to this panel, click "Configure" (or the equivalent in your "system language")?
Control Surface Scripts can only control "configured parameters" that appear in this area.
When your control surface is properly connected through a script, the "configured parameters" shown here reflect the movements on your controller.

Ciura81
Control Surface Studio User
#2

No only the stock instruments works.
NODrumracks,.AudioRacks, No Effects and no VST's working
I imported the scrip for the Midifigther twister and it doesn't work..
I tried effery Step of the Video for Devices like it's in the Video but it does not work.
With the same VST (Massive)
I selected the right midi Channel and the right midie Value)
But it does not work
And I thik to get ever parameter of Operater mapped to my controller is more difficult as for exaple to get the first Knob of the Audioeffectrack to map.

Ciura81
Control Surface Studio User
#3

FIXED it,
it's not possible to use Devices in Deviceselector with Endlessencoders, it's only possible with Knobs.
This is so annoying, because I have to map/ creat a new Controller with over 300 Mappings That are all mapped for the stock Instruments!
Could it be fixed

John C
Forum Admin
#4

Have you tried using a reaction for controlling a device parameter instead?
The option 'get value from ranges' wiithin reactions will be what you need, here's a video tutorial on using it: https://youtu.be/1Bni9Yqtks0