New Year Deal!
Get Control Surface Studio Now For Just $62
Time left to get it...
mailtimers.com
Your shopping cart is empty.

After Ableton Live 11.2.7 update newly created scripts are not in preference list

Submitted by HDV on Tue, 12/20/2022 - 14:42
HDV
Control Surface Studio User

Last week Live has automatically updated to V11.2.7
When I now create a new script, the script is created correctly by CSS (no errors in log) and is stored at the right place, but it´s not listed in Live´s preference list! Restarts don´t change anything! Any hints ????

Dieter

Topic Category: 

10 Responses

Comments

aplastas
Control Surface Studio User
#1

I am seeing this issue as well on a Mac

HDV
Control Surface Studio User
#2

Problem can be solved by checking the settings for "Live version" : select in the right list "Live 11.2.7".
Dieter

clatyonc
Control Surface Studio User
#3

im also having this issue. im running live 11.2.6 - was on live 11.2.5. ive updated the live version in remotify settings to 11.2.6 but after restart live still doesnt see the new script even though i can see it in the midi remote script folder in the mac finder.

anyone got any suggestions to get live to see the new remote script?

Bradford Ross-MacLeod
Control Surface Studio User
#4

I'm having the same issue on 11.2.7. CSS shows the right Live version. Scripts are installing in the correct folder. But they're not showing up in Live midi settings. I'm on Windows 11.

Bradford Ross-MacLeod
Control Surface Studio User
#5

Well now at least I'm getting errors in the log.
Here's what I've got:

---------------------------------
Traceback (most recent call last):
File "", line 1, in
File "C:\ProgramData\Ableton\Live 11 Suite\Resources\MIDI Remote Scripts\css_hy_rpe_test\__init__.py", line 2, in
from css_hy_rpe_test import css_hy_rpe_test
ImportError
:
bad magic number in 'css_hy_rpe_test.css_hy_rpe_test': b'### '
Traceback (most recent call last):
File "", line 1, in
File "C:\ProgramData\Ableton\Live 11 Suite\Resources\MIDI Remote Scripts\css_launch_controlxl_test\__init__.py", line 2, in
from css_launch_controlxl_test import css_launch_controlxl_test
File "C:\ProgramData\Ableton\Live 11 Suite\Resources\MIDI Remote Scripts\css_launch_controlxl_test\css_launch_controlxl_test.py", line 17, in
from itertools import imap, chain
ImportError
:
cannot import name 'imap' from 'itertools' (unknown location)
Traceback (most recent call last):
File "", line 1, in
File "C:\ProgramData\Ableton\Live 11 Suite\Resources\MIDI Remote Scripts\css_twister_hy_rpe2\__init__.py", line 2, in
from css_twister_hy_rpe2 import css_twister_hy_rpe2
File "C:\ProgramData\Ableton\Live 11 Suite\Resources\MIDI Remote Scripts\css_twister_hy_rpe2\css_twister_hy_rpe2.py", line 17, in
from itertools import imap, chain
ImportError
:
cannot import name 'imap' from 'itertools' (unknown location)
Traceback (most recent call last):
File "", line 1, in
File "C:\ProgramData\Ableton\Live 11 Suite\Resources\MIDI Remote Scripts\Twister_Device_Control\__init__.py", line 4, in
from config import *
ModuleNotFoundError
:
No module named 'config'
Traceback (most recent call last):
File "", line 1, in
File "C:\ProgramData\Ableton\Live 11 Suite\Resources\MIDI Remote Scripts\css_hy_rpe_test\__init__.py", line 2, in
from css_hy_rpe_test import css_hy_rpe_test
ImportError
:
bad magic number in 'css_hy_rpe_test.css_hy_rpe_test': b'### '
Traceback (most recent call last):
File "", line 1, in
File "C:\ProgramData\Ableton\Live 11 Suite\Resources\MIDI Remote Scripts\css_launch_controlxl_test\__init__.py", line 2, in
from css_launch_controlxl_test import css_launch_controlxl_test
File "C:\ProgramData\Ableton\Live 11 Suite\Resources\MIDI Remote Scripts\css_launch_controlxl_test\css_launch_controlxl_test.py", line 17, in
from itertools import imap, chain
ImportError
:
cannot import name 'imap' from 'itertools' (unknown location)
Traceback (most recent call last):
File "", line 1, in
File "C:\ProgramData\Ableton\Live 11 Suite\Resources\MIDI Remote Scripts\css_twister_hy_rpe2\__init__.py", line 2, in
from css_twister_hy_rpe2 import css_twister_hy_rpe2
File "C:\ProgramData\Ableton\Live 11 Suite\Resources\MIDI Remote Scripts\css_twister_hy_rpe2\css_twister_hy_rpe2.py", line 17, in
from itertools import imap, chain
ImportError
:
cannot import name 'imap' from 'itertools' (unknown location)
Traceback (most recent call last):
File "", line 1, in
File "C:\ProgramData\Ableton\Live 11 Suite\Resources\MIDI Remote Scripts\Twister_Device_Control\__init__.py", line 4, in
from config import *
ModuleNotFoundError
:
No module named 'config'
-----------------------------
I'm a total noob, so I'm not sure what I need to be looking for here.

VZI
Control Surface Studio User
#6

same here! i tried literally everything but since version 11.2.5. new scripts doesnt show up anymore in preferences... just updated to 11.2.7. cause i thought this would solve the problem... but i find it interesting cause my error log looks different then the ones posted above! i get an Indentation Error, whatever that means...

Traceback (most recent call last):
File "", line 1, in
File "/Applications/Ableton Live 11 Suite.app/Contents/App-Resources/MIDI Remote Scripts/css_loopvisual_xan_test/__init__.py", line 2, in
from .css_loopvisual_xan_test import css_loopvisual_xan_test
File "/Applications/Ableton Live 11 Suite.app/Contents/App-Resources/MIDI Remote Scripts/css_loopvisual_xan_test/css_loopvisual_xan_test.py", line 530
except Exception as e:
^
IndentationError
:
expected an indented block
Traceback (most recent call last):
File "", line 1, in
File "/Applications/Ableton Live 11 Suite.app/Contents/App-Resources/MIDI Remote Scripts/css_xandi_loop_ipad/__init__.py", line 2, in
from .css_xandi_loop_ipad import css_xandi_loop_ipad
File "/Applications/Ableton Live 11 Suite.app/Contents/App-Resources/MIDI Remote Scripts/css_xandi_loop_ipad/css_xandi_loop_ipad.py", line 530
except Exception as e:
^
IndentationError
:
expected an indented block
Traceback (most recent call last):
File "", line 1, in
File "/Applications/Ableton Live 11 Suite.app/Contents/App-Resources/MIDI Remote Scripts/css_loopvisual_xan_new/__init__.py", line 2, in
from .css_loopvisual_xan_new import css_loopvisual_xan_new
File "/Applications/Ableton Live 11 Suite.app/Contents/App-Resources/MIDI Remote Scripts/css_loopvisual_xan_new/css_loopvisual_xan_new.py", line 530
except Exception as e:
^
IndentationError
:
expected an indented block
Traceback (most recent call last):
File "", line 1, in
File "/Applications/Ableton Live 11 Suite.app/Contents/App-Resources/MIDI Remote Scripts/css_loopvisual_xan_test/__init__.py", line 2, in
from .css_loopvisual_xan_test import css_loopvisual_xan_test
File "/Applications/Ableton Live 11 Suite.app/Contents/App-Resources/MIDI Remote Scripts/css_loopvisual_xan_test/css_loopvisual_xan_test.py", line 530
except Exception as e:
^
IndentationError
:
expected an indented block
Traceback (most recent call last):
File "", line 1, in
File "/Applications/Ableton Live 11 Suite.app/Contents/App-Resources/MIDI Remote Scripts/css_xandi_loop_ipad/__init__.py", line 2, in
from .css_xandi_loop_ipad import css_xandi_loop_ipad
File "/Applications/Ableton Live 11 Suite.app/Contents/App-Resources/MIDI Remote Scripts/css_xandi_loop_ipad/css_xandi_loop_ipad.py", line 530
except Exception as e:
^
IndentationError
:
expected an indented block
Traceback (most recent call last):
File "", line 1, in
File "/Applications/Ableton Live 11 Suite.app/Contents/App-Resources/MIDI Remote Scripts/css_loopvisual_xan_new/__init__.py", line 2, in
from .css_loopvisual_xan_new import css_loopvisual_xan_new
File "/Applications/Ableton Live 11 Suite.app/Contents/App-Resources/MIDI Remote Scripts/css_loopvisual_xan_new/css_loopvisual_xan_new.py", line 530
except Exception as e:
^
IndentationError
:
expected an indented block

i really really hope you can help me! i´m gigin two times a week and i would really nedd my updated script... thanks in advance!!!!

tylerputnam
Control Surface Studio User
#7

I had similar issue but after messing with the 'settings' it is working great now. see attached for the paths that worked for me.

upload files: 
John C
Forum Admin
#8

VZI & Bradford, please send your scripts over to me here: john at remoitfy.io
along with your error logs and I will take a look.
You're errors totally separate so it's doubtful they are to do with the same thing.

Bradford - ensure you are using 'python 3' to generate your script. This is in the settings of Control Surface Studio.

I've test a script in Live 11.2.7 and it loads/works correctly so I don't that is the issue.

Thanks

Bradford Ross-MacLeod
Control Surface Studio User
#9

I followed tylerputnam's paths above and now the script are showing up in Ableton, so that's a start.

John, I'm sending you the info you requested, though I have a feeling the errors that are showing up now are due to my inexperience with CSS. But I'd appreciate any feedback you have.

Thanks.

tommy1979
Control Surface Studio User
#10

Also having this problem on 11.2.7 on Mac. The paths are all correct and the version is set correctly. When importing nothing happens, no error message either. Downgrading live to 11.2.5 resolved the issue.