Your shopping cart is empty.

Ableton 10 + PC + MIDI Remote Scripts not working

Submitted by c3r1c3 on Sat, 04/27/2019 - 05:14
c3r1c3
Control Surface Studio User

I think this is a bug, issue and feature request:
I have Ableton Live 10 Lite and am using CSS. Setting everything up, I was able to follow the very nicely written directions (kudos for them, not enough companies make such clear documentation for a product so young), but an interesting issue would happen when I tried to export the script to Ableton. The software button would remain grey and it would never export. The issue was that the path for the "MIDI Remote Script Folder" didn't exist!
So I manually created the path and the scripts starting exporting, but Ableton wouldn't see them until I copied it from the path listed in the software to C:\Program Files\Ableton\Live 10 Lite\Resources\MIDI Remote Scripts .
Now I know that the path listed in CSS is the same as Ableton's online manual, so it should have existed and should be working without any changes on either of our ends, but it happened and so I'm saying something.

I guess what I'm looking for is some type of error message if the above 'never export' thing were to happen again, and the option to change the folder that the files are exported to.

Thank you for your time.

Topic Category: 

2 Responses

Comments

John Carney
Forum Admin
#1

Hi,

Just so i understand this issue correctly, are you saying that you had to manually create the folders in your file system and then the scripts could be exported / Ableton could see them?
If that's the case it sounds like your version of Live didn't automatically setup the MIDI Remote Script Folder, which is strange.

c3r1c3
Control Surface Studio User
#2

Thank you for your reply. Your understanding is correct, sans Ableton being able to see them. Ableton doesn't even look in that folder, so I have to manually copy it over to the C:\Program Files\Ableton\Live 10 Lite\Resources\MIDI Remote Scripts folder for it to show up. Once over there the script works just fine.