SessionBox Navigation does not work

Submitted by aehaem on Tue, 02/06/2018 - 19:55
aehaem
pro user
Hello I have problems to get the sessionBox Navigation to work. I have tried to move the sessionBox with Midi CC commands, and also with Midi Notes. I have tried them as Mode 0, and also tried to repeat them in all Modes I use, except Mode 0... (I currently use up to six modes, but plan to enlarge the script once everythings working) At last I tried to move the Session Box with three additional Modes (leaving the left offset n/a and the top offset in steps by 8 and trigger those Modes by a shift command (the other Modes are triggered by a Mode Button, but have the Top offset set to n/a, so this should also work by my understanding), but this is not working also. In the remotify app I set the notes ( or CC`s ) to trigger the commands with the Midi learn feature, the commands are recognized here and appear as trigger for the mapping I want. When setting the script as ableton live surface, the sessionBox appears and most of my commands are triggered, but some don`t work, the most important for me are sessionBox up and done by page ( I`ve managed the left right with different modes, to have access to my most important tracks, but left right by page and by 1 would also be very joyful...) I have tried different Midi Controllers ( Gordius Little Giant, Roland FC 200, Behringer FCB 1010 and BCR 2000, Xoto Pad and Midi Translator Pro ) but all with the same result. I am working on Windows 7 and Ableton Live 9 Suite. Please help me... Thank you! (I hope you understand my request, since English is not my native, so feel free to ask if somethings unclear)

9 Responses

Comments

John Carney
pro user

Hi Aehaem,

After trying the session box navigation and it doesn't work, if you switch modes do you continue to see the message at the bottom of the screen appear "mode 1 is now activate" etc?
If this stops appearing it means there's probably an error occurring in the script.

John

aehaem
pro user

The modes do appear, so it´s not the script that`s broken, but what else can prohibit that command?
I already tried to delete Ableton for a new installation, I tried with that Remotify surface as only surface (all other slots set to none), all other Controllers switched off and in a new Project with no Midi bindings set (within Ableton Live). I have cancelled connection to my Internet Router and switched all Firewalls and co off...
No Ideas left...
Dennis

John Carney
pro user

Post your log.txt file here and I'll double check its not the script causing a problem.

John

aehaem
pro user

I now have figured out what was wrong.
I have tried to use the SessionBox navigation in Mode 0 (assuming this Mode works within all other Modes).
So I have done MidiBindings to the navigation in all Modes (except 0) and hey presto, it works...
Some secrets seem to be hidden in the documents (?).
The next enigma I am tooth teething is, how to use more then one script in ableton...
Only the upper script in Lives presetting is reacting (when I swap the scipts, it´s the other one reacting).
So if you have some hints for me (even those that seem to be trivial), I would appreciate.
Thank you very much for your help,
sincerely, Dennis

aehaem
pro user

meaning more than one Remotify script. All other scripts work as expected.

John Carney
pro user

Glad you figured out the session box navigation issue,
Hmm I'm pretty sure you can assign more than script to the same midi controller in Ableton. Is it possibly that you're overriding the same controls with the other script?

John

aehaem
pro user

I tried first script commands only for channel 1 and 2, second only channel 3 and 4, so it should not override...
I`ve also tried two different controllers, but only one sessionbox is working (always the upper one).
I Found out, I can control the Remotify SessionBox with ClyphX, but also only the upper one is working...=(

aehaem
pro user

Okay,
seems as if I`ve got it working now, two scripts running together, and clip triggers of both scripts are working...
(started 2 new scripts, only with session Boxes, no other bindings)
So I may start expanding 'em now...

John Carney
pro user

Glad to hear that you got 2 scripts working together!