LED feedback to QuNeo

Submitted by Nevrin on Wed, 09/27/2017 - 15:09
Nevrin
Pro User
Hi, I just purchased Remotify Pro for mapping a QuNeo controller to Ableton However, it doesn't work to receive LED feedback to the QuNeo. For example, I have set up a session box that works, and so does triggering clips, etc. But there is no LED feedback, despite being specified in the mapping. I believe the mapping is correctly setup, with MIDI prefs, etc. The issue is probably that remote LED control on QuNeo is preset for specific MIDI data input (in order to remotely create "light shows" on the controller). Unfortunately this cannot be changed via the QuNeo editor, only via a control script. Here's an example of a script for QuNeo that accomplishes LED feedback for clip control (although I don't want to use that script, for various reasons): https://www.keithmcmillen.com/projects/quneo-ableton-live-control/ Is there someway that this can be solved with Remotify? Or have I missed something? Without being able to receive LED feedback to QuNeo I will unfortunately not have any use for Remotify. Best, Klas

10 Responses

Comments

Nevrin
Pro User

Here a test for a json file that I tried.

upload files: 
John Carney
Forum Admin

Hi Klas,

First thing:
In your link/midi tab of midi preferences (inside Ableton),
Make sure your controller selected in the input and output next to your selectedscript.
Also, ensure that Track & Remote are turned on for the both input and output of your QuNeo.

Feedback should work ok for the QuNeo as another user sent over the feedback color values for it.
You can see them in this forum topic https://remotify.io/community/question/led-feedback-values.

Nevrin
Pro User

Thanks for replying John. Yes the controller is already selected accordingly, and the correct color values have been used in the session box. Unfortunately I believe that the only way to get LED feedback is to use the same CC or Note numbers for the output as the ones that are preset for MIDI input. That's perhaps how another user made this work. But that severely limits the possibilities of mapping the QuNeo.
So as far as I can tell the only other way is to write in the script to override the presets. In the quneo.py script linked above it says the following that might be pertinent:

def _set_mode(self, mode):
self.turn_off_all_buttons()
#CLIP LAUNCH MODE
if (mode == 0):

# BUTTONS TO TURN ON
self.stop_all_clips = self.led_button(GRID_CHANNEL, STOP_ALL_CLIPS, 100)
self.launch_button = self.led_button(GRID_CHANNEL, SLOT_LAUNCH, RED_HI)
for index in range(7):
self.mute_buttons.append(self.led_button(GRID_CHANNEL, TRACK_MUTE[index], GREEN_HI))
self.solo_buttons.append(self.led_button(GRID_CHANNEL, TRACK_SOLO[index], ORANGE_HI))
self.arm_buttons.append(self.led_button(GRID_CHANNEL, TRACK_ARM[index], RED_HI))
self.stop_track_buttons.append(self.led_button(GRID_CHANNEL, STOP_TRACK[index], 100))
for scene in range(4):
self.scene_launch_buttons.append(self.led_button(GRID_CHANNEL, SCENE_LAUNCH[scene], GREEN_LO))

But I don't enough about scripting to know where and how to put this into the remotify script manually. Maybe you could advise? I'm thinking that this issue might come up again with other controllers that also have preset MIDI input CCs and Notes?

Best,
Klas

remoteAdmin
Pro User

Hi Klas,

I've had a read through the QuNeo user manual
https://files.keithmcmillen.com/downloads/quneo/QuNeo_FullManual_1.1.pdf
And also downloaded the ableton script from keith mcmillen.
I haven't seen any indication from either of them that LED feedback needs to be set differently to the midi values of the control itself.

One question, does the script you created through remotify work? as in, the controls on the QuNeo fire the clips in the session box?

John

Nevrin
Pro User

Hi John,

In the QuNeo full manual p. 41 it says: "The LEDs on the QuNeo can be sent MIDI messages to control their behavior. When the QuNeo receives the proper MIDI data for a pad, slider, button, etc., the LEDs will respond accordingly. To learn what MIDI messages can be sent to the LEDs, consult the MIDI Input chapter of the Factory Presets Guide." And on p. 38 (the chapter referenced) it says "Use the MIDI Input guides below to find out what MIDI data to send the QuNeo to control the LEDs remotely". And on page 39 there is an image in which you can see the data that are assigned to the pads (C-2 - F#8) in grid mode with 1 note per corner (the mode I am using), also preset to receive on channel 3.

So unfortunately it does seem to be the case that LED feedback needs to be set differently to the midi values of the control itself. However, the "Ableton presets" supplied with the QuNeo modify this behavior (also stated in the manual), so it's obviously possible to change LED feedback via a script.

The script works fine otherwise. Clips are fired correctly, etc. It's only the LED feedback doesn't work, which seems to be explained by the above facts. I really hope that it will be possible to solve this in some way with Remotify, since otherwise I would need to write script manually - and thus Remotify won't be helpful for me in this particular case. Apart from this particular need it certainly seems to be a great app!

Best,
Klas

Nevrin
Pro User

I should add that I referenced version 1.2.4 of the manual. In your version 1.1 the relevant chapter seems to be on p. 33 and onwards. /klas

John Carney
Forum Admin

Hi Klas,

Thanks for quoting the manual, I had another look and on page 38 titled "Midi Input" it says:
"use Channel 1 as the default LED channel for Pads in drum mode and all other sensor types".

I have an idea which may or may not work. Try creating a copy of your script but set all of the channels in your script to 1. Then assign the 2 versions to your controller in Ableton at the same time.
In theory, this will give you the correct controls in one script and the correct leds for those controls in the other.

I've attached your script with the session box pads set to channel 1.

John

upload files: 
Nevrin
Pro User

Hi John, that didn't work. But I tried using the same MIDI output values as the preset MIDI Input values, and now the LED feedback works. This unfortunately limits the use of QuNeo so I need to be able to change between presets on QuNeo (the modes in Remotify is not an option for this). However, when changing between presets and/or banks on QuNeo the LED feedback is not updated (for example, the leds indicating clips in the session box are put out). Perhaps this has to do with Ableton (using value scaling as Takeover mode). One weird way to update is to press cmd+M twice (for midi mapping), but this won't work for live performance. Do you know of any other way to update the LED feedback for the session box? /Klas

John Carney
Forum Admin

To update LED feedback for the session box, you can switch modes (Remotify modes), if I remember right this re-initialises the session box and therefore all of the LEDs for it too.

I'm a little confused by what you mean here:
"I tried using the same MIDI output values as the preset MIDI Input values, and now the LED feedback works"
With Remotify, you can only send LED information to the same midi values as the MIDI input values on the controller.
Unless I misunderstand what you're saying?

John

Nevrin
Pro User

Ok, good idea, I'll try that!

I meant that in Remotify I set the values to be sent to Ableton as the same ones that QuNeo is preset to receive on. I didn't do that before because by using other values I could get more out of using QuNeo.
Now it works with LED feedback for the session box pads, but I can only use the other QuNeo controllers in a more limited way, unfortunately.

Thanks for your help John!
Best,
Klas